Generated Oct-23 05:44:42 GMT

You are not logged in.

Name: Password:

Or: Recover Account (Forgotten Password) / Register new user / Re-send validation email / Main Page

ADVERTISEMENT

Website Discussion, Bug Reports and Abuse Reports

Problem in #7464

This thread is open.

Posted by lamar 2010-01-16 04:10:11 GMT


Good day. The site changes today seem to have introduced a bug. I just built the coal mine on Rochdale #2. The coal should have replenished the demand track, given me funds in exchange, and left the tile flipped. Instead, the application seems to have concluded that Rochdale is not connected to a port even though its seems to be so.

Thanks.

(And thanks for the site.)

Posted by Hammerite This user is an administrator. 2010-01-16 05:38:47 GMT


I identified the cause of the problem, but a large number of games had been affected by it already. I came to the decision that the most suitable way to fix the problem was to revert to the backup copy from earlier today. Unfortunately that means that people who have made moves while the site was open will have to make them again. Sorry about that. (You don't have to take your move again; I did it myself to check that the problem was fixed.)

I reshuffled the distant market tiles in all of the currently in-progress games, since otherwise some users who made moves and will have the opportunity to re-take them might have an unfair advantage. Unfortunately, due to the way the game log works, that means the logs for all current games are lost. I really am very sorry. :(

Posted by randomuser 2010-01-16 06:21:36 GMT


Hi,

First of all, thanks for taking the time to do the enhancements to the site.

One thing I've noticed in reverting to the backups is that a game which I had completed in that brief time period, 7419, is now listed in the "finished games" space but listed as "in progress" but also lists that I have won that game. Also my rating did not revert (and clicking the manually recalculate link didn't change it) to what it was prior to today.

This sounds like a minor glitch and I'm not sure worth doing anything over, but I thought I would report it in case this is a symptom of a deeper problem I am unaware of.

Should I finish the game again, or is there something else that should happen?

Thanks again for all your work!

Posted by Hammerite This user is an administrator. 2010-01-16 06:26:51 GMT


Yes, please make your move to finish the game again - everything should resolve if you do that. Thanks for your understanding.

Posted by randomuser 2010-01-16 06:31:22 GMT


Great, everything looked like it resolved correctly.

A small thing I noted too. There is a column for "long turns" in the finished games table. What is that for? It also looks like the data in that column may have been transposed with the next column for "score"?

Posted by Hammerite This user is an administrator. 2010-01-16 17:26:51 GMT


Oh yeah, you are right. I will fix that later.

The idea behind "long turns" is that it will keep track of how many times a player took longer than Time Limit A to take his turn. So you can browse that column and see how frequently a user was slower than the game's creator asked. But it's not hooked up to anything yet, so it doesn't count anything just at the moment.

You must log on in order to post messages.

Click here to return to the Board Page, or here to return to the Main Page.