Generated Oct-28 02:07:25 GMT

You are not logged in.

Name: Password:

Or: Recover Account (Forgotten Password) / Register new user / Re-send validation email / Main Page

ADVERTISEMENT

Website Discussion, Bug Reports and Abuse Reports

System won't takeany move

This thread is open.

Posted by anyeone 2009-01-07 15:10:48 GMT


I can't find anything wrong with my move but the "submit move" button does nothing at all. There is no validation error occurring - it is as if I didn't click the button. I tried an alternative move to see if maybe there was a problem with the move, but that didn't work either.

I am using FF 3.0.5, Windows XP. I am logged in. I have JavaScript enabled in the browser.

Game is #43 brass primate 1
My attempted move is:
Build industry (I also tried with a location card that had a cotton mill space)
Cotton mill
Industry space: Bolton 1 (also tried with Bolton 2, and with Blackburn 1 & Blackburn 2 using the Blackburn card)
Port to use (I didn't change it, since it wasn't applicable, but there isn't a "n/a" option)
Canal link to build (tried leaving same and changing it, but it shouldn't be applicable, though there isn't an "n/a" option)
Source of coal: Demand track (also tried Wigan, where someone put a coal mine, even though there is no link)
I didn't change the amount of loan dropdown, it still said 30 but shouldn't be applicable.
Second card to use - coal mine (also tried leaving it at "select one"

There definitely needs to be validation errors if there is a problem with someone's move, but I think this goes beyond that since I tried many combinations of theoretically valid moves and got no response.

Additionally, some things to think about that would be nice once I can actually make a move at all - have you considered having "N/A" options for the dropdowns and having users only set the applicable ones? You can also use Javascript to enable/disable the dropdowns depending on which action the user picks. That would improve usability considerably.
-----

Posted by Hammerite This user is an administrator. 2009-01-07 15:42:47 GMT


Sorry, I changed something earlier today and must have broken the page. I'll fix it now.

Posted by Hammerite This user is an administrator. 2009-01-07 15:44:35 GMT


Please try taking your move again, hopefully it will now submit the form

Posted by anyeone 2009-01-07 18:28:28 GMT


Thanks, that worked now. :)

You must log on in order to post messages.

Click here to return to the Board Page, or here to return to the Main Page.